Kan noen gi meg noen hint om WP-design?

Hei til WP-guruer og WP-designere der ute:

Jeg har endret design på min blogg, og har valgt temaet “AndyBlue”som utgangspunkt. Men kommentarfeltet plasserer seg ikke riktig på siden. Av en eller annen grunn vises dette i midtspalten (som det skal), men først nedenfor sidefeltene og ikke umiddelbart etter innlegget. Det vises f.eks. her: http://blogg.torvund.net/2010/08/23/manglende-skilter-en-henvendelse-til-statens-vegvesen-vegdirektoratet/ (og sikkert på dette innlegget, siden det er så kort at det ikke fyller spalten ned til slutten av sidefeltene).

Er det noen som har noen forslag til hva feilen kan skyldes og hva jeg børe gjøre?

Print Friendly
  • Jeg installerte temaet og tok en forhåndsvisning og da fungerte det greit hos meg. Sånn umiddelbart ville jeg prøvd å installert et annet tema og deretter installere AndyBlue igjen. Funker ikek det, så ville jeg fjernet Widgetene, da jeg har lest at noen kan skape problemer og deretter legge til en og en for å se om det fungerer.

  • Jeg ser øverst til høyre så har du share/save som widget. Jeg har hatt den selv, og mener bestemt at den skal ligge i innlegget og ikke som en widget. Tror det er der problemet ditt ligger.

  • Kjetil

    Har tatt et dypt dykk i koden på sida, men var fryktelig vanskelig å finne ut hva som kan skyldes at det blir slik.
    Kan du teste å skru av Disqus-plugin som du har installert for bedre kommentering? Bare deaktiver den, så ser vi fort om det er den som har skylden, eller om det ligger i det nye temaet.

  • Hans Magnus

    Det kjem av at kommentarfeltet er Disqus-generert, og da legg på uheldig CSS for ditt oppsett. Det burde funke rett ut av boksen, men her gjer det ikkje det. Om du skrur av Disqus-kommentar (kanskje i plugin admin), ser du at det ordner seg. Du kan sjå det same om du blokkerer javascript fra disqus.com (via webdev verktøy, f.eks Firebug for Firefox).

  • Nå har jeg deaktivert Disqus, og da ser det litt bedre ut.

    Hans Magnus, går det an å skru på CSS for Disqus? Jeg merker meg at den er plassert riktig mens den laster inn, men så legger seg feil når den er ferdig med å laste.

  • I og med at det er en “Save & Share” i temaet har jeg også fjernet AddThis widget. Trenger den uansett ikke to ganger. Skal fikle litt mer med dette senere, men har ikke tid nå.

    Takk for innspill så langt.

  • Etter å ha deaktivert “AddThis” gjorde jeg et kort forsøk på å reaktivere Disqus. Og det reintroduserte også straks feilen. Så det er åpenbart at det er Disqus som utløser problemet, enten selve feilen ligger i Disqus eller temaet. Så jeg får stille Disqus i bero, og gjøre en test fra tid til annen når det kommer nye versjoner.

    Takk for alle innspill.

  • En underlig sideeffekt av å deaktivere Disqus var at mange av mine egne kommentarer plutselig sto om anonyme. Jeg ønsker på ingen måte å være anonym, særlig ikke på egen blogg. Forhåpentligvis har jeg funnet alle og brakt dem ut av anonymitetens mørke.